The program can't start because wlanapi.dll is missing

  • 1
  • Problem
  • Updated 1 year ago
The app is working fine on my laptop.  Users were complaining that the PowerPoint presentation was choppy (which I assume is because of bandwidth).  So I tried hosting the conference on one of my cloud servers (Amazon AWS).  I installed the app fine, but when I try to start a personal meeting, it says:

The program can't start because Wlanapi.dll is missing from your computer.  Try reinstalling the program to fix this problem.

I tried another server and I got the same error.  Maybe the app does not let you host a meeting over RDP?  I have the camera and audio turned off, but it still doesn't work.  Again, I wanted to share my desktop and present the Powerpoint slideshow, using the high pipe available from AWS (500Mb).

-Chad
Photo of Chad Kuester

Chad Kuester

  • 80 Points 75 badge 2x thumb

Posted 2 years ago

  • 1
Hello Chad!

If you are having trouble with the wlanapi.dll file missing, it can be related to a number of issues. I have an informative article that goes into details on what causes these types of errors for reference:
Please let me know if this article is helpful!
Photo of Chad Kuester

Chad Kuester

  • 80 Points 75 badge 2x thumb
I've now taken a brand new Server 2012 R2 machine.  Your app was the first app I've installed on it.  It installed just fine.  The app will open, but immediately comes up with the same Wlanapi.dll error.

All of the items mentioned in the article (virus, malware, etc) should not be an issue with a newly formatted and installed OS.

I checked Event Viewer.  I don't see any errors that would help trace this.

Any other recommendations?

Thanks,
-Chad
Hello Chad,

We currently do not support connectivity on Windows Server OS. For Windows, we support Vista, 7, 8, & 10. Do you have a device with native Windows or Mac OSX software on it? This is the reason we are getting the wlanapi.dll error.
Photo of Douglas Gray

Douglas Gray

  • 90 Points 75 badge 2x thumb
just install the wireless lan service and that should go away