Screenshare not visible to participants

  • 1
  • Question
  • Updated 1 year ago
What are the troubleshooting steps when a user cannot share their screen? This is an experienced Bluejeans user who has a new laptop. When I share my screen, she can see it. When she shares her screen- I just see a black screen on my side...not only me, all users get a black screen when she tries to share. ON her end it appears normal?
Photo of John Hickey

John Hickey

  • 70 Points

Posted 2 years ago

  • 1
Photo of Radhika@BJsupport

Radhika@BJsupport, Official Rep

  • 6,048 Points 5k badge 2x thumb
Hi John,

Thank you for reporting this issue. Seeing black screen instead of shared content on browser session is very unusual. As this issue is experienced across multiple users we need to gather more information from user who is presenting:  
  1. What is the machine specification used by user who is sharing content?
  2. Does issue exist when user try screen share from different browser or bluejeans app?
  3. Which application user is trying to share ( ex: entire desktop/ specific application) ?
  4. Participants who are viewing black screen are they connected in meeting from same type of browsers/bluejeans app?
In addition to above information if we can get plugin logs from one of the affected machine along with presenter machine logs we can investigate more.

Kindly click here for finding log upload instructions.
 
Thank you,
Photo of Martin Tessun

Martin Tessun

  • 90 Points 75 badge 2x thumb
Just some additional information on this:
This does always happen, in case you have more than one screen.
If a window that is shown on the secondary screen is shared it simply is sent as a black window. Moving the Window to the primary screen does update the content of the Window in BJNS correctly.
Photo of Marina Kalinin

Marina Kalinin

  • 140 Points 100 badge 2x thumb
Martin, did you have Wayland or you are running RHEL?
echo $XDG_SESSION_TYPE
Photo of Martin Tessun

Martin Tessun

  • 90 Points 75 badge 2x thumb
I am using NVIDIA and therefore X (no Wayland support for NVIDIA drivers)
Photo of Marina Kalinin

Marina Kalinin

  • 140 Points 100 badge 2x thumb
Check this bug, if you are running recent Fedora: https://bugzilla.redhat.com/show_bug.cgi?id=1392072
Photo of Marina Kalinin

Marina Kalinin

  • 140 Points 100 badge 2x thumb
If it is the case and your X is now Wayland, you can change it to Gnome+Xorg on your login screen and try again. It solved my problem.