Mac OS X microphone level automatically adjusting during idle times picking up background noise

  • 2
  • Problem
  • Updated 3 months ago
This is huge problem.  It's happening during every group meeting.  It interrupts trains of thought and lines of communication when we have to stop to say "Joe, can you mute, we're picking up background noise"

The problem is that something is automatically adjusting the microphone's sensitivity level.  When you Google this problem, a lot of people report it in a lot of applications.

Some people claim it's the Mac OS X operating system.  Indeed, for the MacBook's built-in mic, there is a "Use ambient noise reduction" option.  But that's only for the one built into the housing of the MacBook.  There is no such optional for a microphone on a connected display, or a USB headset/microphone.  There are even suggested hacks to continually set the microphone to a hard-coded level.

Others claim it's an application problem, often citing Google Hangouts or Skype.  Indeed, some claim you can hack it (e.g. hack it in Google Hangouts).

If the latter is the case, then I would hope Blue Jeans can fix this too.  I've already done a quick and dirty grep through the "~/Applications/Blue Jeans.app/Contents" and "~/Library/Application Support/Blue Jeans".

Having the app detect an optimum level isn't a bad idea.  But it shouldn't do it continually.  Or, at least, it should be togglable.

For example, during a stand-up meeting, people each take a turn stating their status.  Occasionally, people inquire about someone's status as they're stating it.  So you have a group of people that are all listening, but mostly silent.  So the individual user's systems sense that they're not picking up significant audio during their quiet times, and increase the sensitivity level.  Pretty soon the mic is picking up background noise and amplifying as loud as their voice would've been.  This starts to drown out the person who is speaking.

Muting is a work-around, not a solution.  Even with the convenience of the spacebar, I have to first focus the Blue Jeans window to do that.  A global hot key might be a better work-around, but it still only avoids the problem.

I'd much prefer a "calibrate microphone level" that engaged a detection of the proper level and then froze it there until told otherwise.
Photo of Brian Sayatovic

Brian Sayatovic

  • 142 Points 100 badge 2x thumb
  • frustrated

Posted 2 years ago

  • 2
Photo of Manish Parmar

Manish Parmar

  • 304 Points 250 badge 2x thumb
So it is a Mac issue that we experienced with Skype for Business and BlueJeans.  The only way we were able to resolve this was by using a headset or USB speakerphone device rather than a standard microphone and separate speakers.

When the headset or USB Speakerphone is used, Mac doesn't try to control the input gain.
Photo of Brian Sayatovic

Brian Sayatovic

  • 142 Points 100 badge 2x thumb
That differs from my experience (and that of my team). We've had this using built in MacBook mic, external display mic (Apple Display through Thunderbolt connector), and through simple Plantronic USB headset.
Photo of Manish Parmar

Manish Parmar

  • 304 Points 250 badge 2x thumb
Interesting, our only experience with a Mac is the 2016 iMac.  We have two of them and they both had the mic issue with the built-in mic.  As soon as we plugged in a headset(the standard Apple headphones), the auto-gain had stopped.  The users didn't like having to wear a headset so we then moved on to a USB speakerphone(ClearONE).

Maybe the MacBooks are different than the iMacs.
Photo of Darcie Callahan

Darcie Callahan

  • 60 Points
FYI -- I am having this issue with a 2011 iMac.  
Photo of Mike Kerr

Mike Kerr, Official Rep

  • 1,530 Points 1k badge 2x thumb
Hi Brian,

Thank you for your detailed message. Really appreciate it. Have reviewed your comments with our audio engineers.

BlueJeans is very aware of this concern, as we encounter it ourselves, and hear about it from other customers. One difficultly is that some users do want the microphone to be sensitive. For instance, if they have a mic at one end of room and someone is talking toward a whiteboard on the other side of the room - the mic gain needs to raise up to let other people hear them speak. Manish offers a good suggestion with the USB device connections to prevent the gain control.

Our focus is to get better at telling the difference between useful speech, and unwanted noise. We have plans to improve our ability to remove the bothersome noise, while still allowing the microphone to boost distance voices that are wanted.

Mike
Photo of Brian Sayatovic

Brian Sayatovic

  • 142 Points 100 badge 2x thumb
That sounds promising, but I encourage you to consider also just adding a simple toggle (whether it's buried deep, or prominent next to video/mic toggles) to enable/disable the adjustment, or even to manually set the level.
Photo of Brian Sayatovic

Brian Sayatovic

  • 116 Points 100 badge 2x thumb
Has there been any update on this?  It's been 6 months.  The problem is _really_ bad.  People have been muting as a work-around, but then people forget they're muted and _that_ causes problems.  It really shouldn't be any harder than just talking to people in a physical room.

Some of the people in my company have already dumped Blue Jeans for Google Hangouts, claiming that it does NOT have the auto-adjusting mic problem.  I fear the rest of the company may follow suit if there's no progress on this issue.
Photo of Lee Snyder

Lee Snyder, Official Rep

  • 5,434 Points 5k badge 2x thumb
Hello Brian,

We are still working on our new integration with Dolby Laboratories for our audio codec. This will improve the audio quality in meetings immensely. You can read our press release on this partnership here:

https://www.bluejeans.com/press-releases/dolby-laboratories-bluejeans-network-innovate-to-power-supe...

It is only available by request, as there are some caveats to the system:
  • Video Share has audio choppiness

  • Un-muting after staying on mute for a period of time on the desktop app causes the user's voice volume to fluctuate

  • We have resolved a number of lip syncing issues, but you may still experience problems with lip sync in your meetings

If you would like to hear how this integration sounds, I will be happy to give you a demo.

Regards,
Lee - BlueJeans Support 
Photo of Brian Sayatovic

Brian Sayatovic

  • 116 Points 100 badge 2x thumb
Sounds interesting in its own right, but I don't think it will solve our problem.  If the mic volume is still able to fluctuate on its own, then we're doomed.  We all have to fight with muting.  Some of us have even bought Shush as a work-around.  $5 is cheap, but the fact that I have to shell out money to work-around a problem is still frustrating in principle.  I don't mind having the computer help determine the right mic level, but it should only do so when I need it, not all the time.  I'm sure you've seen the parody video of people attending a conference call.  The part with the people talking while on mute... that happens all the time.  Losing one minute of a 10-minute stand-up do people fighting mute is a 10% time cost.  It adds up time, not to mention frustration.  I shouldn't have to mute simply to overcome some feature that wants to increase the microphone gain until it detects some audio (like a bird chirping in the distance) when I simply have nothing to say at that time.  And then when I do speak, it has to crank back down.  Mu my mouth and close talk mic haven't changed positions.  So why adjust the gain?  It's infuriating.
Photo of Tim Trepagnier

Tim Trepagnier

  • 60 Points
Hi I'm having this problem as a result of being forced to used the standalone application. I do videoconferencing support for a living and this auto gain issue is unacceptable. Please advise. 
Photo of Lee Snyder

Lee Snyder, Official Rep

  • 4,884 Points 4k badge 2x thumb
Hello Tim,

We are working on this with our new audio integration with Dolby Laboratories and hope that when this new integration is released it will alleviate the automatic gain issues that are faced with our current codec.

You can read more about our partnership with Dolby here: https://www.bluejeans.com/dolby-voice

If you would like, I can set up a time with you personally to give you a demonstration on how Dolby sounds in a meeting. If you are interested, let me know and I will schedule a consult!

Regards,
Lee - BlueJeans Support
Photo of Matt Johnson

Matt Johnson

  • 60 Points
We're using Bluejeans with Audio Technica mics and having major issues on our live shows where the mic gain level is consistently moving up and down completely out of relation to any movement of the speaker. He is sitting at a desk and facing the computer. Is there ANY way to completely turn off gain-level monitoring at the BlueJeans level to prevent this when it's clearly not in the best interest of the speaker or the audience?
Photo of Lee Snyder

Lee Snyder, Official Rep

  • 4,884 Points 4k badge 2x thumb
Hello Matt,

We currently do not have a way to turn on or off automatic gain control in the system. We are working on a new audio codec that will improve the overall audio in meetings, as well as gain control.

This codec is in early access, you can email support@bluejeans.com to request the codec.

Regards,
Lee - BlueJeans Support